What actually happened
Two flaws were found in PHP itself — the software that runs the back end of a huge share of the web. Nicknamed PHP2Shell, they are tracked as CVE-2026-109618 and CVE-2026-109619, and both are rated 9.2 out of 10 for severity. That is about as serious as these ratings go.
In plain terms: under the right conditions, an attacker on the internet could make a PHP website run commands it was never meant to run — without any password. That is the kind of hole used to deface a site, steal what is in its database, or quietly plant malware that infects your visitors.
The details leaked a day early, on 20 October, so the PHP team released the fix ahead of schedule on the 21st. That is good news: the patch exists. The risk now is every site that has not applied it yet.
The facts, briefly
- What it is
- Two critical PHP flaws (PHP2Shell)
- Tracking numbers
CVE-2026-109618,CVE-2026-109619- Severity
- 9.2 / 10 — critical
- Patched on
- 21 October 2026
- Fixed versions
- PHP 8.5.12, 8.4.27, 8.3.36, 8.2.35
- Who it affects
- Any website serving pages with PHP
Are you exposed?
You almost certainly run PHP if any of these is true. You do not need to know the technical details — the point is simply that PHP is probably involved.
- Your site is built on WordPress. WordPress is PHP. This is the single most common case for businesses.
- You are on shared or cPanel hosting — GoDaddy, Bluehost, HostGator, Hostinger, Namecheap and the like. These almost all serve PHP.
- Your site uses Joomla, Drupal, Magento or an older custom build. All PHP.
- You are not sure what your site is built on. That by itself is worth a two-minute check.
Two reassuring exceptions: sites built on Squarespace, Wix, Shopify or Webflow are run by those companies, who patch their own servers — you do not have to do anything. And a site that is plain static pages, with no PHP at all, is not affected by this.
What to do
- Find out if your site runs PHP, and which version. If you are on a managed builder (Squarespace, Wix, Shopify), you are covered — stop here. Otherwise, keep going.
- Ask your host or web person to confirm the patch is applied. The fixed versions are 8.5.12, 8.4.27, 8.3.36 or 8.2.35. A good host will have done this automatically; many have not. It is a fair question to ask them today.
- If your PHP version is older than 8.2, you have a bigger problem. Those versions are end-of-life: the PHP project no longer ships updates for them, so any fix depends on your host or vendor. The real fix is to move off them, which is a good idea for most sites anyway.
- Keep your plugins and themes updated. On WordPress, outdated add-ons are the usual way these holes actually get exploited. Update them, and remove any you do not use.
We are not going to pretend this is a five-minute job you should fear. For most owners it is one honest conversation with whoever runs your site. If you do not have that person, that is what we are for.